Flowforth

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Delay In Sending
Resolved·Degraded performance

Sending is fully restored. If you run into any further issues, please email us at support@flowforth.co

Mon, Jun 22, 2026, 09:24 PM
(2 months ago)
·
Affected components
Jun 22, 2026, 08:58 PM
09:10 PM
Email Sending
Automations
Updates

Resolved

Sending is fully restored. If you run into any further issues, please email us at support@flowforth.co

Mon, Jun 22, 2026, 09:24 PM

Monitoring

Email sending should be restored, and any emails sent during the down period should now be delivered. We are monitoring for any further regressions.

Mon, Jun 22, 2026, 09:10 PM(14 minutes earlier)

Identified

Email sending is currently delayed due to an issue with a downstream provider. We are working to restore services now. All emails will be sent as expected when service is restored.

Mon, Jun 22, 2026, 08:58 PM(11 minutes earlier)