Flowforth

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Increased Errors in Accessing Dashboard
Resolved·Partial outage

This issue has been resolved and all services are back online. No emails failed to send in this period. If you have any issues accessing the Flowforth dashboard, please contact support@flowforth.co.

Wed, Jun 17, 2026, 07:58 PM
(3 months ago)
·
Affected components
Jun 17, 2026, 07:45 PM
07:58 PM
Email Sending
Application
Updates

Resolved

This issue has been resolved and all services are back online. No emails failed to send in this period. If you have any issues accessing the Flowforth dashboard, please contact support@flowforth.co.

Wed, Jun 17, 2026, 07:58 PM

Monitoring

Our downstream provider has pushed a fix for this issue. We are monitoring to ensure that access is fully restored.

Wed, Jun 17, 2026, 07:54 PM

Investigating

We're currently investigating an increase in errors in accessing the Flowforth dashboard.

Wed, Jun 17, 2026, 07:51 PM